AutoSSL is a new cPanel feature which was enabled on the server following an automatic update to the server software. We do not support or monitor their renewals so they could expire without anyone being aware, and any change to the server could stop it from functioning correctly.

We do not recommend relying on them. If you need an SSL cert for your website, we offer our own certs which we install and manage for you. For more information on our managed SSL certs, please visit https://www.letshost.ie/hosting/ssl/ If you do not need an SSL cert for your website, you can ignore this warning you received.

If you require further information/assistance on this, please submit a ticket and a member of the team will be happy to assist further.